import re
regex = re.compile(r"^5$", flags=re.MULTILINE)
test_str = ("Match ENTIRE LINE of these lines:\n\n"
"1,2,3,4\n"
"-1,2,-3,4,-5\n"
"1000,100,10,1,0\n"
"5\n\n"
"and NONE of these:\n\n"
"2,3,\n"
",,,\n"
"-,-\n"
"3-2,4-5\n"
"-50,up\n"
"down,20\n"
"apple,banana,pear\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")