re = /^5$/m
str = 'Match ENTIRE LINE of these lines:
1,2,3,4
-1,2,-3,4,-5
1000,100,10,1,0
5
and NONE of these:
2,3,
,,,
-,-
3-2,4-5
-50,up
down,20
apple,banana,pear
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end