using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^5$";
string input = @"Match ENTIRE LINE of these lines:
1,2,3,4
-1,2,-3,4,-5
1000,100,10,1,0
5
and NONE of these:
2,3,
,,,
-,-
3-2,4-5
-50,up
down,20
apple,banana,pear
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}