const regex = /^5$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^5$', 'gm')
const str = `Match ENTIRE LINE of these lines:
1,2,3,4
-1,2,-3,4,-5
1000,100,10,1,0
5
and NONE of these:
2,3,
,,,
-,-
3-2,4-5
-50,up
down,20
apple,banana,pear
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}