#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)(<h3>.*?</h3>)((?:my-class(*SKIP)(*F)|.)*?)(<p>.*?</p>)"
Local $sString = "<h3>Header</h3>" & @CRLF & _
"<img />" & @CRLF & _
"<p>some text</p>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"нужно чтобы он пропустил это" & @CRLF & _
"" & @CRLF & _
"<h3>Header</h3>" & @CRLF & _
"<img />" & @CRLF & _
"<div class="my-class">content</div>" & @CRLF & _
"<p>some text</p>" & @CRLF & _
"" & @CRLF & _
"<h3>Header</h3>" & @CRLF & _
"<img />" & @CRLF & _
"<p>some text</p>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")