using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<h3>.*?</h3>)((?:my-class(*SKIP)(*F)|.)*?)(<p>.*?</p>)";
string input = @"<h3>Header</h3>
<img />
<p>some text</p>
нужно чтобы он пропустил это
<h3>Header</h3>
<img />
<div class=""my-class"">content</div>
<p>some text</p>
<h3>Header</h3>
<img />
<p>some text</p>
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}