const regex = new RegExp('(<h3>.*?</h3>)((?:my-class(*SKIP)(*F)|.)*?)(<p>.*?</p>)', 'isg')
const str = `<h3>Header</h3>
<img />
<p>some text</p>
нужно чтобы он пропустил это
<h3>Header</h3>
<img />
<div class="my-class">content</div>
<p>some text</p>
<h3>Header</h3>
<img />
<p>some text</p>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}