re = /(<h3>.*?<\/h3>)((?:my-class(*SKIP)(*F)|.)*?)(<p>.*?<\/p>)/i
str = '<h3>Header</h3>
<img />
<p>some text</p>
нужно чтобы он пропустил это
<h3>Header</h3>
<img />
<div class="my-class">content</div>
<p>some text</p>
<h3>Header</h3>
<img />
<p>some text</p>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end