// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?is)(<h3>.*?</h3>)((?:my-class(*SKIP)(*F)|.)*?)(<p>.*?</p>)").unwrap();
let string = "<h3>Header</h3>
<img />
<p>some text</p>
нужно чтобы он пропустил это
<h3>Header</h3>
<img />
<div class=\"my-class\">content</div>
<p>some text</p>
<h3>Header</h3>
<img />
<p>some text</p>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}