import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<h3>.*?</h3>)((?:my-class(*SKIP)(*F)|.)*?)(<p>.*?</p>)";
final String string = "<h3>Header</h3>\n"
+ "<img />\n"
+ "<p>some text</p>\n\n\n"
+ "нужно чтобы он пропустил это\n\n"
+ "<h3>Header</h3>\n"
+ "<img />\n"
+ "<div class=\"my-class\">content</div>\n"
+ "<p>some text</p>\n\n"
+ "<h3>Header</h3>\n"
+ "<img />\n"
+ "<p>some text</p>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}