use strict;
my $str = '<h3>Header</h3>
<img />
<p>some text</p>
нужно чтобы он пропустил это
<h3>Header</h3>
<img />
<div class="my-class">content</div>
<p>some text</p>
<h3>Header</h3>
<img />
<p>some text</p>
';
my $regex = qr~(<h3>.*?</h3>)((?:my-class(*SKIP)(*F)|.)*?)(<p>.*?</p>)~isp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}