#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*(usluga\d+).*"
Local $sString = "btn btn-default usluga_btn usluga1" & @CRLF & _
"usluga_btn usluga1" & @CRLF & _
"btn usluga_btn usluga1" & @CRLF & _
"btn btn-default usluga_btn usluga2" & @CRLF & _
"usluga_btn usluga2" & @CRLF & _
"btn usluga_btn usluga2" & @CRLF & _
"btn btn-default usluga_btn usluga1" & @CRLF & _
"usluga_btn usluga1" & @CRLF & _
"btn usluga_btn usluga1" & @CRLF & _
"btn btn-default usluga_btn usluga2" & @CRLF & _
"usluga_btn usluga2" & @CRLF & _
"btn usluga_btn usluga2" & @CRLF & _
"" & @CRLF & _
"чтобы из 'btn btn-default usluga3_btn' " & @CRLF & _
"и из 'btn btn-default usluga_btn usluga3'" & @CRLF & _
" вытаскивалось usluga3 без _btn"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")