$re = '/.*(usluga\d+).*/';
$str = 'btn btn-default usluga_btn usluga1
usluga_btn usluga1
btn usluga_btn usluga1
btn btn-default usluga_btn usluga2
usluga_btn usluga2
btn usluga_btn usluga2
btn btn-default usluga_btn usluga1
usluga_btn usluga1
btn usluga_btn usluga1
btn btn-default usluga_btn usluga2
usluga_btn usluga2
btn usluga_btn usluga2
чтобы из \'btn btn-default usluga3_btn\'
и из \'btn btn-default usluga_btn usluga3\'
вытаскивалось usluga3 без _btn';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);