// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*(usluga\d+).*").unwrap();
let string = "btn btn-default usluga_btn usluga1
usluga_btn usluga1
btn usluga_btn usluga1
btn btn-default usluga_btn usluga2
usluga_btn usluga2
btn usluga_btn usluga2
btn btn-default usluga_btn usluga1
usluga_btn usluga1
btn usluga_btn usluga1
btn btn-default usluga_btn usluga2
usluga_btn usluga2
btn usluga_btn usluga2
чтобы из 'btn btn-default usluga3_btn'
и из 'btn btn-default usluga_btn usluga3'
вытаскивалось usluga3 без _btn";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}