package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*(usluga\d+).*`)
var str = `btn btn-default usluga_btn usluga1
usluga_btn usluga1
btn usluga_btn usluga1
btn btn-default usluga_btn usluga2
usluga_btn usluga2
btn usluga_btn usluga2
btn btn-default usluga_btn usluga1
usluga_btn usluga1
btn usluga_btn usluga1
btn btn-default usluga_btn usluga2
usluga_btn usluga2
btn usluga_btn usluga2
чтобы из 'btn btn-default usluga3_btn'
и из 'btn btn-default usluga_btn usluga3'
вытаскивалось usluga3 без _btn`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}