import re
regex = re.compile(r".*(usluga\d+).*")
test_str = ("btn btn-default usluga_btn usluga1\n"
"usluga_btn usluga1\n"
"btn usluga_btn usluga1\n"
"btn btn-default usluga_btn usluga2\n"
"usluga_btn usluga2\n"
"btn usluga_btn usluga2\n"
"btn btn-default usluga_btn usluga1\n"
"usluga_btn usluga1\n"
"btn usluga_btn usluga1\n"
"btn btn-default usluga_btn usluga2\n"
"usluga_btn usluga2\n"
"btn usluga_btn usluga2\n\n"
"чтобы из 'btn btn-default usluga3_btn' \n"
"и из 'btn btn-default usluga_btn usluga3'\n"
" вытаскивалось usluga3 без _btn")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")