import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(usluga\\d+).*";
final String string = "btn btn-default usluga_btn usluga1\n"
+ "usluga_btn usluga1\n"
+ "btn usluga_btn usluga1\n"
+ "btn btn-default usluga_btn usluga2\n"
+ "usluga_btn usluga2\n"
+ "btn usluga_btn usluga2\n"
+ "btn btn-default usluga_btn usluga1\n"
+ "usluga_btn usluga1\n"
+ "btn usluga_btn usluga1\n"
+ "btn btn-default usluga_btn usluga2\n"
+ "usluga_btn usluga2\n"
+ "btn usluga_btn usluga2\n\n"
+ "чтобы из 'btn btn-default usluga3_btn' \n"
+ "и из 'btn btn-default usluga_btn usluga3'\n"
+ " вытаскивалось usluga3 без _btn";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}