# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^]*?\((\d{3})\)\s*(\d+)-(\d+)\s*\(Main\)[^]*/$1-$2-$3/;t' <<< "
(555) 555-5555 (Main)
,
(777) 777-777 (Domestic Fax)
"