const regex = /^[^]*?\((\d{3})\)\s*(\d+)-(\d+)\s*\(Main\)[^]*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^]*?\\((\\d{3})\\)\\s*(\\d+)-(\\d+)\\s*\\(Main\\)[^]*', '')
const str = `
(555) 555-5555 (Main)
,
(777) 777-777 (Domestic Fax)
`;
const subst = `$1-$2-$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);