package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^]*?\((\d{3})\)\s*(\d+)-(\d+)\s*\(Main\)[^]*`)
var str = []byte(`
(555) 555-5555 (Main)
,
(777) 777-777 (Domestic Fax)
`)
var substitution = []byte("$1-$2-$3")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}