$re = '/^[^]*?\((\d{3})\)\s*(\d+)-(\d+)\s*\(Main\)[^]*/';
$str = '
(555) 555-5555 (Main)
,
(777) 777-777 (Domestic Fax)
';
$subst = "$1-$2-$3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;