using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^]*?\((\d{3})\)\s*(\d+)-(\d+)\s*\(Main\)[^]*";
string substitution = @"$1-$2-$3";
string input = @"
(555) 555-5555 (Main)
,
(777) 777-777 (Domestic Fax)
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}