#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^[^]*?\((\d{3})\)\s*(\d+)-(\d+)\s*\(Main\)[^]*"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" (555) 555-5555 (Main)" & @CRLF & _
"" & @CRLF & _
", " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" (777) 777-777 (Domestic Fax)" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$1-$2-$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)