import Foundation
let pattern = #"^[^]*?\((\d{3})\)\s*(\d+)-(\d+)\s*\(Main\)[^]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
(555) 555-5555 (Main)
,
(777) 777-777 (Domestic Fax)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1-$2-$3"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}