#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\.GetModification(?:String|Number|Bool|Object|Array)\((?:\s*["']([\w\-]+)['"]\s*,\s*(["'][^"]*['"]|[+-]?(?:\d*[.])?\d+|true|false|False|True)(?:\s*,\s*(?:true|false|\d+|"[^"]*"))?\s*\))?"
Local $sString = " discountName, err := fsVisitor.GetModificationString("btnColor", "VString", true)" & @CRLF & _
" discountName, err := fsVisitor.GetModificationNumber("btnSize", 13, true)" & @CRLF & _
" discountName, err := fsVisitor.GetModificationBool("showBtn", false, true)" & @CRLF & _
"" & @CRLF & _
" discountName, err := fsVisitor.GetModificationString("btnColor", "VString")" & @CRLF & _
" discountName, err := fsVisitor.GetModificationNumber("btnSize", 13)" & @CRLF & _
" discountName, err := fsVisitor.GetModificationBool("showBtn", false)" & @CRLF & _
"" & @CRLF & _
" discountName, err := fsVisitor.GetModificationString("btnColor", "VString")" & @CRLF & _
" discountName, err := fsVisitor.GetModificationNumber("btnSize", "red, green, blue")" & @CRLF & _
" discountName, err := fsVisitor.GetModificationBool("showBtn", "(false, red)")" & @CRLF & _
"" & @CRLF & _
" discountName, err := fsVisitor.GetModificationBool(showBtn, "(false, red)")"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")