import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.GetModification(?:String|Number|Bool|Object|Array)\\((?:\\s*[\"']([\\w\\-]+)['\"]\\s*,\\s*([\"'][^\"]*['\"]|[+-]?(?:\\d*[.])?\\d+|true|false|False|True)(?:\\s*,\\s*(?:true|false|\\d+|\"[^\"]*\"))?\\s*\\))?";
final String string = " discountName, err := fsVisitor.GetModificationString(\"btnColor\", \"VString\", true)\n"
+ " discountName, err := fsVisitor.GetModificationNumber(\"btnSize\", 13, true)\n"
+ " discountName, err := fsVisitor.GetModificationBool(\"showBtn\", false, true)\n\n"
+ " discountName, err := fsVisitor.GetModificationString(\"btnColor\", \"VString\")\n"
+ " discountName, err := fsVisitor.GetModificationNumber(\"btnSize\", 13)\n"
+ " discountName, err := fsVisitor.GetModificationBool(\"showBtn\", false)\n\n"
+ " discountName, err := fsVisitor.GetModificationString(\"btnColor\", \"VString\")\n"
+ " discountName, err := fsVisitor.GetModificationNumber(\"btnSize\", \"red, green, blue\")\n"
+ " discountName, err := fsVisitor.GetModificationBool(\"showBtn\", \"(false, red)\")\n\n"
+ " discountName, err := fsVisitor.GetModificationBool(showBtn, \"(false, red)\")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}