import Foundation
let pattern = #"\.GetModification(?:String|Number|Bool|Object|Array)\((?:\s*["']([\w\-]+)['"]\s*,\s*(["'][^"]*['"]|[+-]?(?:\d*[.])?\d+|true|false|False|True)(?:\s*,\s*(?:true|false|\d+|"[^"]*"))?\s*\))?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
discountName, err := fsVisitor.GetModificationString("btnColor", "VString", true)
discountName, err := fsVisitor.GetModificationNumber("btnSize", 13, true)
discountName, err := fsVisitor.GetModificationBool("showBtn", false, true)
discountName, err := fsVisitor.GetModificationString("btnColor", "VString")
discountName, err := fsVisitor.GetModificationNumber("btnSize", 13)
discountName, err := fsVisitor.GetModificationBool("showBtn", false)
discountName, err := fsVisitor.GetModificationString("btnColor", "VString")
discountName, err := fsVisitor.GetModificationNumber("btnSize", "red, green, blue")
discountName, err := fsVisitor.GetModificationBool("showBtn", "(false, red)")
discountName, err := fsVisitor.GetModificationBool(showBtn, "(false, red)")
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)