use strict;
my $str = ' discountName, err := fsVisitor.GetModificationString("btnColor", "VString", true)
discountName, err := fsVisitor.GetModificationNumber("btnSize", 13, true)
discountName, err := fsVisitor.GetModificationBool("showBtn", false, true)
discountName, err := fsVisitor.GetModificationString("btnColor", "VString")
discountName, err := fsVisitor.GetModificationNumber("btnSize", 13)
discountName, err := fsVisitor.GetModificationBool("showBtn", false)
discountName, err := fsVisitor.GetModificationString("btnColor", "VString")
discountName, err := fsVisitor.GetModificationNumber("btnSize", "red, green, blue")
discountName, err := fsVisitor.GetModificationBool("showBtn", "(false, red)")
discountName, err := fsVisitor.GetModificationBool(showBtn, "(false, red)")';
my $regex = qr/\.GetModification(?:String|Number|Bool|Object|Array)\((?:\s*["']([\w\-]+)['"]\s*,\s*(["'][^"]*['"]|[+-]?(?:\d*[.])?\d+|true|false|False|True)(?:\s*,\s*(?:true|false|\d+|"[^"]*"))?\s*\))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}