// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\.GetModification(?:String|Number|Bool|Object|Array)\((?:\s*["']([\w\-]+)['"]\s*,\s*(["'][^"]*['"]|[+-]?(?:\d*[.])?\d+|true|false|False|True)(?:\s*,\s*(?:true|false|\d+|"[^"]*"))?\s*\))?"#).unwrap();
let string = " discountName, err := fsVisitor.GetModificationString(\"btnColor\", \"VString\", true)
discountName, err := fsVisitor.GetModificationNumber(\"btnSize\", 13, true)
discountName, err := fsVisitor.GetModificationBool(\"showBtn\", false, true)
discountName, err := fsVisitor.GetModificationString(\"btnColor\", \"VString\")
discountName, err := fsVisitor.GetModificationNumber(\"btnSize\", 13)
discountName, err := fsVisitor.GetModificationBool(\"showBtn\", false)
discountName, err := fsVisitor.GetModificationString(\"btnColor\", \"VString\")
discountName, err := fsVisitor.GetModificationNumber(\"btnSize\", \"red, green, blue\")
discountName, err := fsVisitor.GetModificationBool(\"showBtn\", \"(false, red)\")
discountName, err := fsVisitor.GetModificationBool(showBtn, \"(false, red)\")";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}