re = /\.GetModification(?:String|Number|Bool|Object|Array)\((?:\s*["']([\w\-]+)['"]\s*,\s*(["'][^"]*['"]|[+-]?(?:\d*[.])?\d+|true|false|False|True)(?:\s*,\s*(?:true|false|\d+|"[^"]*"))?\s*\))?/m
str = ' discountName, err := fsVisitor.GetModificationString("btnColor", "VString", true)
discountName, err := fsVisitor.GetModificationNumber("btnSize", 13, true)
discountName, err := fsVisitor.GetModificationBool("showBtn", false, true)
discountName, err := fsVisitor.GetModificationString("btnColor", "VString")
discountName, err := fsVisitor.GetModificationNumber("btnSize", 13)
discountName, err := fsVisitor.GetModificationBool("showBtn", false)
discountName, err := fsVisitor.GetModificationString("btnColor", "VString")
discountName, err := fsVisitor.GetModificationNumber("btnSize", "red, green, blue")
discountName, err := fsVisitor.GetModificationBool("showBtn", "(false, red)")
discountName, err := fsVisitor.GetModificationBool(showBtn, "(false, red)")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end