const regex = /\.GetModification(?:String|Number|Bool|Object|Array)\((?:\s*["']([\w\-]+)['"]\s*,\s*(["'][^"]*['"]|[+-]?(?:\d*[.])?\d+|true|false|False|True)(?:\s*,\s*(?:true|false|\d+|"[^"]*"))?\s*\))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.GetModification(?:String|Number|Bool|Object|Array)\\((?:\\s*["\']([\\w\\-]+)[\'"]\\s*,\\s*(["\'][^"]*[\'"]|[+-]?(?:\\d*[.])?\\d+|true|false|False|True)(?:\\s*,\\s*(?:true|false|\\d+|"[^"]*"))?\\s*\\))?', 'gm')
const str = ` discountName, err := fsVisitor.GetModificationString("btnColor", "VString", true)
discountName, err := fsVisitor.GetModificationNumber("btnSize", 13, true)
discountName, err := fsVisitor.GetModificationBool("showBtn", false, true)
discountName, err := fsVisitor.GetModificationString("btnColor", "VString")
discountName, err := fsVisitor.GetModificationNumber("btnSize", 13)
discountName, err := fsVisitor.GetModificationBool("showBtn", false)
discountName, err := fsVisitor.GetModificationString("btnColor", "VString")
discountName, err := fsVisitor.GetModificationNumber("btnSize", "red, green, blue")
discountName, err := fsVisitor.GetModificationBool("showBtn", "(false, red)")
discountName, err := fsVisitor.GetModificationBool(showBtn, "(false, red)")`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}