#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z]+(?:-?\d)+$"
Local $sString = "shop----------------1" & @CRLF & _
"shop-1---------1" & @CRLF & _
"shop1" & @CRLF & _
"shop2" & @CRLF & _
"shop-1" & @CRLF & _
"shop-2" & @CRLF & _
"shop-1-2" & @CRLF & _
"shop-1-2-3" & @CRLF & _
"1-2-shop"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")