re = /^[a-z]+(?:-?\d)+$/m
str = 'shop----------------1
shop-1---------1
shop1
shop2
shop-1
shop-2
shop-1-2
shop-1-2-3
1-2-shop'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end