using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z]+(?:-?\d)+$";
string input = @"shop----------------1
shop-1---------1
shop1
shop2
shop-1
shop-2
shop-1-2
shop-1-2-3
1-2-shop";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}