package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z]+(?:-?\d)+$`)
var str = `shop----------------1
shop-1---------1
shop1
shop2
shop-1
shop-2
shop-1-2
shop-1-2-3
1-2-shop`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}