const regex = /^[a-z]+(?:-?\d)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z]+(?:-?\\d)+$', 'gm')
const str = `shop----------------1
shop-1---------1
shop1
shop2
shop-1
shop-2
shop-1-2
shop-1-2-3
1-2-shop`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}