import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z]+(?:-?\\d)+$";
final String string = "shop----------------1\n"
+ "shop-1---------1\n"
+ "shop1\n"
+ "shop2\n"
+ "shop-1\n"
+ "shop-2\n"
+ "shop-1-2\n"
+ "shop-1-2-3\n"
+ "1-2-shop";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}