#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)\/\*.*?\*\/|\/+[^)]*?$"
Local $sString = ".test {" & @CRLF & _
" background-image: url(//www.google.com/image/1.png); // goole // iamge" & @CRLF & _
"}" & @CRLF & _
"@font-face {" & @CRLF & _
" font-display: auto;" & @CRLF & _
" font-family: vant-icon; ////// blah// !!!" & @CRLF & _
" font-style: normal;" & @CRLF & _
" font-weight: 400;" & @CRLF & _
" src: url(https://at.alicdn.com/t/c/font_2553510_kfwma2yq1rs.woff2?t=1694918397022)" & @CRLF & _
" format("woff2")," & @CRLF & _
" url("https://at.alicdn.com/t/c/font_2553510_kfwma2yq1rs.woff?t=1694918397022")" & @CRLF & _
" format("woff");" & @CRLF & _
"}" & @CRLF & _
"/**" & @CRLF & _
" Some comment" & @CRLF & _
"*/ body {" & @CRLF & _
" color: /* some nice" & @CRLF & _
"color */ gold;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")