import re
regex = re.compile(r"\/\*.*?\*\/|\/+[^)]*?$", flags=re.DOTALL | re.MULTILINE)
test_str = (".test {\n"
" background-image: url(//www.google.com/image/1.png); // goole // iamge\n"
"}\n"
"@font-face {\n"
" font-display: auto;\n"
" font-family: vant-icon; ////// blah// !!!\n"
" font-style: normal;\n"
" font-weight: 400;\n"
" src: url(https://at.alicdn.com/t/c/font_2553510_kfwma2yq1rs.woff2?t=1694918397022)\n"
" format(\"woff2\"),\n"
" url(\"https://at.alicdn.com/t/c/font_2553510_kfwma2yq1rs.woff?t=1694918397022\")\n"
" format(\"woff\");\n"
"}\n"
"/**\n"
" Some comment\n"
"*/ body {\n"
" color: /* some nice\n"
"color */ gold;\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")