// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sm)\/\*.*?\*\/|\/+[^)]*?$").unwrap();
let string = ".test {
background-image: url(//www.google.com/image/1.png); // goole // iamge
}
@font-face {
font-display: auto;
font-family: vant-icon; ////// blah// !!!
font-style: normal;
font-weight: 400;
src: url(https://at.alicdn.com/t/c/font_2553510_kfwma2yq1rs.woff2?t=1694918397022)
format(\"woff2\"),
url(\"https://at.alicdn.com/t/c/font_2553510_kfwma2yq1rs.woff?t=1694918397022\")
format(\"woff\");
}
/**
Some comment
*/ body {
color: /* some nice
color */ gold;
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}