const regex = /\/\*.*?\*\/|\/+[^)]*?$/gsm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\*.*?\\*\\\/|\\\/+[^)]*?$', 'gsm')
const str = `.test {
background-image: url(//www.google.com/image/1.png); // goole // iamge
}
@font-face {
font-display: auto;
font-family: vant-icon; ////// blah// !!!
font-style: normal;
font-weight: 400;
src: url(https://at.alicdn.com/t/c/font_2553510_kfwma2yq1rs.woff2?t=1694918397022)
format("woff2"),
url("https://at.alicdn.com/t/c/font_2553510_kfwma2yq1rs.woff?t=1694918397022")
format("woff");
}
/**
Some comment
*/ body {
color: /* some nice
color */ gold;
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}