use strict;
my $str = '.test {
background-image: url(//www.google.com/image/1.png); // goole // iamge
}
@font-face {
font-display: auto;
font-family: vant-icon; ////// blah// !!!
font-style: normal;
font-weight: 400;
src: url(https://at.alicdn.com/t/c/font_2553510_kfwma2yq1rs.woff2?t=1694918397022)
format("woff2"),
url("https://at.alicdn.com/t/c/font_2553510_kfwma2yq1rs.woff?t=1694918397022")
format("woff");
}
/**
Some comment
*/ body {
color: /* some nice
color */ gold;
}';
my $regex = qr/\/\*.*?\*\/|\/+[^)]*?$/smp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}