#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^(?<wave>[1-9AE]|1[0-4])(?<variable>\w+)"
Local $sString = "3educ" & @CRLF & _
"Aage" & @CRLF & _
"14abc" & @CRLF & _
"Ekajshklasjf" & @CRLF & _
"Zljhfksdfj"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")