$re = '/(?i)^(?<wave>[1-9AE]|1[0-4])(?<variable>\w+)/m';
$str = '3educ
Aage
14abc
Ekajshklasjf
Zljhfksdfj';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);