package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)^(?<wave>[1-9AE]|1[0-4])(?<variable>\w+)`)
var str = `3educ
Aage
14abc
Ekajshklasjf
Zljhfksdfj`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}