const regex = new RegExp('(?i)^(?<wave>[1-9AE]|1[0-4])(?<variable>\\w+)', 'gm')
const str = `3educ
Aage
14abc
Ekajshklasjf
Zljhfksdfj`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}