using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)^(?<wave>[1-9AE]|1[0-4])(?<variable>\w+)";
string input = @"3educ
Aage
14abc
Ekajshklasjf
Zljhfksdfj";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}