re = /(?i)^(?<wave>[1-9AE]|1[0-4])(?<variable>\w+)/m
str = '3educ
Aage
14abc
Ekajshklasjf
Zljhfksdfj'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end