# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/type(?!3\.)\d+\.value(\d+)=\K\d+(?=[\s\S]*?type3\.value\1=(\d+))/\2/gm;t' <<< "type1.value1=60
type1.value2=15
type2.value1=50
type2.value2=18
type3.value1=72
type3.value2=14"