# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"type(?!3\.)\d+\.value(\d+)=\K\d+(?=[\s\S]*?type3\.value\1=(\d+))"
test_str = ("type1.value1=60\n"
"type1.value2=15\n"
"type2.value1=50\n"
"type2.value2=18\n"
"type3.value1=72 \n"
"type3.value2=14")
subst = "\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.